Jun 202010
 
  • Betrifft: Microsoft Exchange Server 2007
  • System: Microsoft Windows Server 2003 R2 x64 Edition, Microsoft Windows Server 2008 x64 Edition, Microsoft Windows Server 2008 R2
  • Problem: Im Outlook Web Access werden keine Bilder angezeigt. Die Anmeldung ist erfolgreich.

Hintergrund

Meist passiert dieser Fehler nach dem Einspielen eines Update Rollups für den Exchange Server 2007 auf dem die Client-Access Rolle installiert ist. Zeitweise kann dies auch in anderen Fällen vorkommen, wenn das Setup (RTM, SP1, SP2) aus irgendeinen Grund abbricht: Exchange Server 2007 SP2 bricht bei der Installation ab.

Bei jedem Setup (RTM, SP1, SP2) oder Update Rollup für den Exchange Server wird im „ClientAccess“ Ordner für Outlook Web Access ein neuer Unterordner erstellt. Dieses ist unter folgenden Pfad zu finden:

C:\Programme\Microsoft\Exchange Server\ClientAccess\Owa

exchange_empty_owa

Dieser wird nach folgendem Schema angelegt:

Bezeichnung Hauptversion Servicepack Update Rollup Release
8 X YYY Z
Exchange Server 2007 RTM 8 0 685 24
Exchange Server 2007 SP1 8 1 240 5
Exchange Server 2007 SP2 8 2 176 2

Der letztgültige Pfad ist dabei immer der höchste nummerierte Ordner. Auf diesen verweist der Exchange Server 2007 automatisch um nach den Bildern zu suchen. Dieser Ordner darf dabei nie leer sein!

exchange_owa_folder

Behebung

Zum einen kann dieser Ordner leer sein, zum anderen kann es sein, dass der Ordner fehlt. Sofern der Ordner vorhanden ist, so hilft es meistens nichts, wenn man die Dateien von einer älteren Version kopiert. Probieren kann man es trotzdem.

Wie auch immer. Es gibt ein spezielles Powershell Skript, dass bei jeder Exchange Server Installation mit der Client-Access Rolle im folgenden Ordner zu finden ist:

C:\Programme\Microsoft\Exchange Server\Bin

Dieses Skript muss ausgeführt werden. Dann sollten alle Probleme mit OWA behoben sein.

  1. Zum Ausführen muss dabei „Exchange-Verwaltungsshell“ geöffnet werden. Dieses ist unter „Alle Programme“ zu finden. exchange_repair_owa1
  2. Das neu erschienene Fenster erinnert dabei stark an die Windows Command Shell (=> „cmd“). Funktioniert aber etwas anders und bietet vor allem mehr Funktionsvielfalt.exchange_repair_owa2
  3. Nun muss man in den richtigen Ordner wechseln. Das geht mit folgendem Befehl:
    cd „C:\Programme\Microsoft\Exchange Server\Bin“

    exchange_repair_owa3

  4. Nun einfach das Skript mit folgenden Befehl ausführen:
    .\UpdateOWA.ps1
  5. Es kein Neustart erforderlich. Ab der nächsten Anmeldung in Outlook Web Access sollten wieder alle Bilder normal angezeigt werden.

weitere relevante Beiträge...

  3 Antworten zu “Im Outlook Web Access werden keine Bilder angezeigt”

Kommentare (1) Pingbacks (2)
  1. funktioniert wunderbar, Danke!

 Antworten

Du kannst diese HTML Tags und Attribute benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(erforderlich)

(erforderlich)