Dez 192011
 
  • Betrifft: Benachrichtigungsdienst für Systemereignisse – eine Creative Sound Blaster mit X-Fi Chip ist verbaut
  • System: Microsoft Windows Vista, Windows 7, Server 2008 x64, Windows Server 2008 R2 x64
  • Problem: Der Startvorgang dauert länger als sonst und nach dem Anmelden erscheint plötzlich unten rechts neben der Uhr eine Warnung, dass keine Verbindung zu einem Dienst hergestellt werden konnte. Nebenbei wird das Windows Basis Schema (keine Aero Oberfläche) dargestellt.

Hintergrund

Der Startvorgang dauert länger als gewöhnlich. Zeitweise scheint der Computer bei "Warten auf Gruppenrichtlinienclient" oder ähnliches etwas zu hängen. Nach dem Anmelden erhält man eine merkwürdige Warnung angezeigt. Diese erscheint aus dem Systray (Benachrichtigungsfeld) heraus – also neben der Uhr.

no_contact_to_service

Deutsch Englisch
Es konnte keine Verbindung mit einem Windows-Dienst hergestellt. Failed to connect to a windows service.
Es konnte keine Verbindung mit dem Dienst "Benachrichtigungsdienst für Systemereignisse" hergestellt werden. Daher können sich Standardbenutzer nicht am System anmelduen. Wenn Sie Administrator sind, finden Sie weitere Details zu diesem Fehler im Systemereignisse. Windows could not connect to the System Event Notification Service service. This problem prevents limited users from logging on to the system. As an administrative user, you can review the System Event Log for details about why the service didn’t respond.

Manchmal wird auch das Windows Basis-Schema angezeigt. Die hardwarebeschleunigte Aero-Oberfläche wurde somit deaktiviert.

 

Damit erfolgt der nächste Schritt zu den Diensten, jedoch scheint der "Benachrichtigungsdienst für Systemereignisse" bzw. "System Event Notification Service " gestartet zu sein. Dieser Dienst wird auch automatisch beim Startvorgang gestartet. In den Systemereignissen findet man ebenso keine weiteren Hinweise. Bei dem Versuch den Dienst neu zu starten erhält man eine Fehlermeldung.

system_event_notification_service_error

Deutsch Englisch
Der Dienst "Benachrichtigungsdienst für Systemereignisse" auf "Lokaler Computer" konnte nicht beendet werden.

Fehler 997: Überlappender E/A-Vorgang wird verarbeitet.

Windows Could not stop the "System Event Notification Service service" on "Local Computer".

Error 997: Overlapped I/O operation is in progress.

Nun steht als Status statt "gestartet" der Vermerk "wird beendet". Nach der Aktualisierung der Anzeige ist der Dienst manchmal beendet. Wenn man nun den Dienst startet und wieder beendet dann kommt wieder die obige Fehlermeldung. Im Internet findet man oft die unterschiedlichsten Hinweise oder Empfehlungen. Leider kann aufgrund der zentralen Bedeutung des Dienstes beinahe alles Schuld sein: jede Hardware, jede andere Software. Der Dienst wird oft für weitere Dienste oder Programme verwendet um Systemereignisse auszulösen oder darauf reagieren zu können.

 

Behebung

Mein Tipp ist es nach anderen Diensten zu suchen, die automatisch starten sollten, aber nicht gestartet sind. Alternativ kann der Status "wird gestartet" vermerkt sein. Systemprogramme könnten ebenfalls beteiligt sein. Dazu zählen recht gerne Antivirenprogramme. Diese haben aber ebenso unter Dienste einen Eintrag, der dann hängt.

 

In meinem Fall entdeckte ich den Dienst "Creative Audio Service" mit dem Vermerk "wird gestartet". Ich konnte den Dienst weder beenden noch sonst etwas abändern. Somit deaktivierte ich das automatisch starten und startete Windows neu. Nun war wieder alles wie gewohnt. Die digitale Soundausgabe funktionierte aber nicht mehr. Jedenfalls war klar, es lag an der Soundkarte.

Ich betreibe eine Creative Sound Blaster X-Fi Titanium HD mit dem Beta-Treiberpaket 3.00.1009 (=> XFRL_PCDRVBETA_US_3_00_1009.exe). Dies ist der letztgültige Treiber vom September 2011. Der offizielle mit WHQL Zertifizierung ist vom Februar 2011 und damit bedeutend älter.

soundblaster_xfi_modus

Ich habe mir geholfen indem ich nach langem hin und her den Soundmodus von Unterhaltungsmodus" auf "Spielmodus" gegeben habe. In diesem Modus läuft die Soundkarte standardmäßig nach erfolgreicher Installation.

Die Schritte wären: via Creative Lautstärkefenster den "Spielmodus aktivieren", danach den Creative Audio Service wieder automatisch mit Windows starten lassen und gleich ohne Neustart im laufenden Betrieb manuell starten. Nun noch mal kontrollieren, ob der Modus richtig ist und wieder die "Dolby Digital Live" Funktion aktivieren. Damit erhält man die digitale Ausgabe für 5.1 Surroundanlagen – ansonsten gibt es überhaupt keine Ausgabe.

Bei längeren Versuchen dürfte definitiv die "Dolby Digital Live" Funktion nicht in jedem Zustand sauber arbeiten. Das ist auch der Grund warum ich den Beta Treiber verwende. In der offiziellen Version gibt es weitere Fehler, die andere Probleme verursachen…

weitere relevante Beiträge...

  2 Antworten zu “keine Verbindung mit Benachrichtungsdienst für Systemereignisse”

Kommentare (2)
  1. Danke für den Tipp, bei Kirchner lag es auch an der Soundkarte.
    Einfach einen neuen Treiber installiert und alles lief wieder.
    Danke!

 Antworten

Du kannst diese HTML Tags und Attribute benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(erforderlich)

(erforderlich)